using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[.]*\/([\-\w]*?\-\d+)";
string input = @"feature/ABC-123-test-message
Improvement/XYZ-ABC-321-Crazy-Name
abc-123-do-it
simple-branch-name
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}