package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[.]*\/([\-\w]*?\-\d+)`)
var str = `feature/ABC-123-test-message
Improvement/XYZ-ABC-321-Crazy-Name
abc-123-do-it
simple-branch-name
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}