$re = '/[.]*\/([\-\w]*?\-\d+)/m';
$str = 'feature/ABC-123-test-message
Improvement/XYZ-ABC-321-Crazy-Name
abc-123-do-it
simple-branch-name
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);