import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[.]*\\/([\\-\\w]*?\\-\\d+)";
final String string = "feature/ABC-123-test-message\n"
+ "Improvement/XYZ-ABC-321-Crazy-Name\n"
+ "abc-123-do-it\n"
+ "simple-branch-name\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}