#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "import(?:["'\s]*([\w*{}\n, ]+)from\s*)?["'\s]*([@\w/_-]+)["'\s].*"
Local $sString = "import React from "react"" & @CRLF & _
"import { Admin, Api, BackstageApisRestClient } from "backstage-admin"" & @CRLF & _
"" & @CRLF & _
"import MultiContentListView from "./views/ListView"" & @CRLF & _
"import MultiContentAddView from "./views/AddView"" & @CRLF & _
"import MultiContentEditView from "./views/EditView""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")