import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "import(?:[\"'\\s]*([\\w*\\{\\}\\n, ]+)from\\s*)?[\"'\\s]*([@\\w/_-]+)[\"'\\s].*";
final String string = "import React from \"react\"\n"
+ "import { Admin, Api, BackstageApisRestClient } from \"backstage-admin\"\n\n"
+ "import MultiContentListView from \"./views/ListView\"\n"
+ "import MultiContentAddView from \"./views/AddView\"\n"
+ "import MultiContentEditView from \"./views/EditView\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}