using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"import(?:[""'\s]*([\w*{}\n, ]+)from\s*)?[""'\s]*([@\w/_-]+)[""'\s].*";
string input = @"import React from ""react""
import { Admin, Api, BackstageApisRestClient } from ""backstage-admin""
import MultiContentListView from ""./views/ListView""
import MultiContentAddView from ""./views/AddView""
import MultiContentEditView from ""./views/EditView""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}