// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"import(?:["'\s]*([\w*{}\n, ]+)from\s*)?["'\s]*([@\w/_-]+)["'\s].*"#).unwrap();
let string = "import React from \"react\"
import { Admin, Api, BackstageApisRestClient } from \"backstage-admin\"
import MultiContentListView from \"./views/ListView\"
import MultiContentAddView from \"./views/AddView\"
import MultiContentEditView from \"./views/EditView\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}