package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`import(?:["'\s]*([\w*{}\n, ]+)from\s*)?["'\s]*([@\w/_-]+)["'\s].*`)
var str = `import React from "react"
import { Admin, Api, BackstageApisRestClient } from "backstage-admin"
import MultiContentListView from "./views/ListView"
import MultiContentAddView from "./views/AddView"
import MultiContentEditView from "./views/EditView"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}