#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(\d+)\s*:\s*(\d+)\s*([ap])\.\s*m\."
Local $sString = "2:0 a. m." & @CRLF & _
"2:0 p. m." & @CRLF & _
"3:0 p. m." & @CRLF & _
"3:0p.m." & @CRLF & _
"" & @CRLF & _
"2:0 am"
Local $sSubst = "$1:$2 $3m"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)