package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(\d+)\s*:\s*(\d+)\s*([ap])\.\s*m\.`)
var str = `2:0 a. m.
2:0 p. m.
3:0 p. m.
3:0p.m.
2:0 am`
var substitution = "$1:$2 $3m"
fmt.Println(re.ReplaceAllString(str, substitution))
}