use strict;
my $str = '2:0 a. m.
2:0 p. m.
3:0 p. m.
3:0p.m.
2:0 am';
my $regex = qr/\b(\d+)\s*:\s*(\d+)\s*([ap])\.\s*m\./mp;
my $subst = '$1:$2 $3m';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";