import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\d+)\\s*:\\s*(\\d+)\\s*([ap])\\.\\s*m\\.";
final String string = "2:0 a. m.\n"
+ "2:0 p. m.\n"
+ "3:0 p. m.\n"
+ "3:0p.m.\n\n"
+ "2:0 am";
final String subst = "$1:$2 $3m";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}