using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\d+)\s*:\s*(\d+)\s*([ap])\.\s*m\.";
string substitution = @"$1:$2 $3m";
string input = @"2:0 a. m.
2:0 p. m.
3:0 p. m.
3:0p.m.
2:0 am";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}