# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/##\S*?##|((?:(?!##\S*?##)\S)+)//gm;t' <<< "http://google.com?this_is_my_encodedurl##somethin##&email=##other##tr"