#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)##\S*?##|((?:(?!##\S*?##)\S)+)"
Local $sString = "http://google.com?this_is_my_encodedurl##somethin##&email=##other##tr"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)