import Foundation
let pattern = ###"##\S*?##|((?:(?!##\S*?##)\S)+)"###
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ###"http://google.com?this_is_my_encodedurl##somethin##&email=##other##tr"###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)