$re = '/##\S*?##|((?:(?!##\S*?##)\S)+)/m';
$str = 'http://google.com?this_is_my_encodedurl##somethin##&email=##other##tr';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;