re = /##\S*?##|((?:(?!##\S*?##)\S)+)/m
str = 'http://google.com?this_is_my_encodedurl##somethin##&email=##other##tr'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result