use strict;
my $str = 'http://google.com?this_is_my_encodedurl##somethin##&email=##other##tr';
my $regex = qr/##\S*?##|((?:(?!##\S*?##)\S)+)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";