using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":\h*\d+px\h+\d+\K;";
string substitution = @"px;";
string input = @"width: 12px 0;
width: 24px 0;";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}