const regex = /:\h*\d+px\h+\d+\K;/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':\\h*\\d+px\\h+\\d+\\K;', 'gm')
const str = `width: 12px 0;
width: 24px 0;`;
const subst = `px;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);