use strict;
my $str = 'width: 12px 0;
width: 24px 0;';
my $regex = qr/:\h*\d+px\h+\d+\K;/mp;
my $subst = 'px;';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";