$re = '/:\h*\d+px\h+\d+\K;/m';
$str = 'width: 12px 0;
width: 24px 0;';
$subst = "px;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;