re = /:\h*\d+px\h+\d+\K;/m
str = 'width: 12px 0;
width: 24px 0;'
subst = 'px;'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result