using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"select\s+([\w ,]+)\s+from\s+(\w+)(?:\s+where([\w =]+))?";
string input = @"select color, year from car where color = blue and year = 2002
select color, year from car";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}