// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)select\s+([\w ,]+)\s+from\s+(\w+)(?:\s+where([\w =]+))?").unwrap();
let string = "select color, year from car where color = blue and year = 2002
select color, year from car";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}