import re
regex = re.compile(r"select\s+([\w ,]+)\s+from\s+(\w+)(?:\s+where([\w =]+))?", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("select color, year from car where color = blue and year = 2002\n"
"select color, year from car")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")