re = /select\s+([\w ,]+)\s+from\s+(\w+)(?:\s+where([\w =]+))?/mi
str = 'select color, year from car where color = blue and year = 2002
select color, year from car'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end