$re = '/select\s+([\w ,]+)\s+from\s+(\w+)(?:\s+where([\w =]+))?/mi';
$str = 'select color, year from car where color = blue and year = 2002
select color, year from car';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);