#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:::|[^:])*+):(?!.*(?<!:):(?!:))"
Local $sString = "JohnP: random text here" & @CRLF & _
"BobF::student: random text here (this is valid because there's only ONE occurrence of a single colon. the other is a double colon)" & @CRLF & _
"Paris: random text here::student (valid for the same reason as above)" & @CRLF & _
"JohnP: student: random text here" & @CRLF & _
"BobF::student: random text here: more" & @CRLF & _
"Bill:: xyz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")