# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?:::|[^:])*+):(?!.*(?<!:):(?!:))"
test_str = ("JohnP: random text here\n"
"BobF::student: random text here (this is valid because there's only ONE occurrence of a single colon. the other is a double colon)\n"
"Paris: random text here::student (valid for the same reason as above)\n"
"JohnP: student: random text here\n"
"BobF::student: random text here: more\n"
"Bill:: xyz")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.