const regex = /^((?:::|[^:])*+):(?!.*(?<!:):(?!:))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:::|[^:])*+):(?!.*(?<!:):(?!:))', 'gm')
const str = `JohnP: random text here
BobF::student: random text here (this is valid because there's only ONE occurrence of a single colon. the other is a double colon)
Paris: random text here::student (valid for the same reason as above)
JohnP: student: random text here
BobF::student: random text here: more
Bill:: xyz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}