import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:::|[^:])*+):(?!.*(?<!:):(?!:))";
final String string = "JohnP: random text here\n"
+ "BobF::student: random text here (this is valid because there's only ONE occurrence of a single colon. the other is a double colon)\n"
+ "Paris: random text here::student (valid for the same reason as above)\n"
+ "JohnP: student: random text here\n"
+ "BobF::student: random text here: more\n"
+ "Bill:: xyz";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}