$re = '/^((?:::|[^:])*+):(?!.*(?<!:):(?!:))/m';
$str = 'JohnP: random text here
BobF::student: random text here (this is valid because there\'s only ONE occurrence of a single colon. the other is a double colon)
Paris: random text here::student (valid for the same reason as above)
JohnP: student: random text here
BobF::student: random text here: more
Bill:: xyz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);