use strict;
my $str = 'JohnP: random text here
BobF::student: random text here (this is valid because there\'s only ONE occurrence of a single colon. the other is a double colon)
Paris: random text here::student (valid for the same reason as above)
JohnP: student: random text here
BobF::student: random text here: more
Bill:: xyz';
my $regex = qr/^((?:::|[^:])*+):(?!.*(?<!:):(?!:))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}