#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^---+\r?\n---+[\w ]+---+(?!(?:\r?\n.*iDontWant.*$)+\r?\n---)(?:\r?\n.*$)+?(?=\r?\n---+$)"
Local $sString = "---------------------------------------------" & @CRLF & _
"-------------------group 1-------------------" & @CRLF & _
"someRandomFile.php A:\iWant\someFolder" & @CRLF & _
"someRandomFile.php A:\iWant\someFolder" & @CRLF & _
"someRandomFile.php A:\iWant\someFolder" & @CRLF & _
"---------------------------------------------" & @CRLF & _
"-------------------group 2-------------------" & @CRLF & _
"someRandomFile.php A:\iDontWant\someFolder" & @CRLF & _
"someRandomFile.php A:\iDontWant\someFolder" & @CRLF & _
"---------------------------------------------" & @CRLF & _
"-------------------group 3-------------------" & @CRLF & _
"someRandomFile.xml A:\iWant\someFolder" & @CRLF & _
"someRandomFile.xml A:\iWant\someFolder" & @CRLF & _
"---------------------------------------------" & @CRLF & _
"-------------------group 4-------------------" & @CRLF & _
"someRandomFile.xml A:\iDontWant\someFolder" & @CRLF & _
"someRandomFile.xml A:\butWathever\someFolder" & @CRLF & _
"---------------------------------------------" & @CRLF & _
"-------------------group 5-------------------" & @CRLF & _
"someRandomFile.xml A:\iWant\someFolder" & @CRLF & _
"someRandomFile.xml A:\iWant\someFolder" & @CRLF & _
"---------------------------------------------" & @CRLF & _
"---------------------------------------------" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")