# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^---+\r?\n---+[\w ]+---+(?!(?:\r?\n.*iDontWant.*$)+\r?\n---)(?:\r?\n.*$)+?(?=\r?\n---+$)"
test_str = ("---------------------------------------------\n"
"-------------------group 1-------------------\n"
"someRandomFile.php A:\\iWant\\someFolder\n"
"someRandomFile.php A:\\iWant\\someFolder\n"
"someRandomFile.php A:\\iWant\\someFolder\n"
"---------------------------------------------\n"
"-------------------group 2-------------------\n"
"someRandomFile.php A:\\iDontWant\\someFolder\n"
"someRandomFile.php A:\\iDontWant\\someFolder\n"
"---------------------------------------------\n"
"-------------------group 3-------------------\n"
"someRandomFile.xml A:\\iWant\\someFolder\n"
"someRandomFile.xml A:\\iWant\\someFolder\n"
"---------------------------------------------\n"
"-------------------group 4-------------------\n"
"someRandomFile.xml A:\\iDontWant\\someFolder\n"
"someRandomFile.xml A:\\butWathever\\someFolder\n"
"---------------------------------------------\n"
"-------------------group 5-------------------\n"
"someRandomFile.xml A:\\iWant\\someFolder\n"
"someRandomFile.xml A:\\iWant\\someFolder\n"
"---------------------------------------------\n"
"---------------------------------------------\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.