use strict;
my $str = '---------------------------------------------
-------------------group 1-------------------
someRandomFile.php A:\\iWant\\someFolder
someRandomFile.php A:\\iWant\\someFolder
someRandomFile.php A:\\iWant\\someFolder
---------------------------------------------
-------------------group 2-------------------
someRandomFile.php A:\\iDontWant\\someFolder
someRandomFile.php A:\\iDontWant\\someFolder
---------------------------------------------
-------------------group 3-------------------
someRandomFile.xml A:\\iWant\\someFolder
someRandomFile.xml A:\\iWant\\someFolder
---------------------------------------------
-------------------group 4-------------------
someRandomFile.xml A:\\iDontWant\\someFolder
someRandomFile.xml A:\\butWathever\\someFolder
---------------------------------------------
-------------------group 5-------------------
someRandomFile.xml A:\\iWant\\someFolder
someRandomFile.xml A:\\iWant\\someFolder
---------------------------------------------
---------------------------------------------
';
my $regex = qr/^---+\r?\n---+[\w ]+---+(?!(?:\r?\n.*iDontWant.*$)+\r?\n---)(?:\r?\n.*$)+?(?=\r?\n---+$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}