import Foundation
let pattern = #"^---+\r?\n---+[\w ]+---+(?!(?:\r?\n.*iDontWant.*$)+\r?\n---)(?:\r?\n.*$)+?(?=\r?\n---+$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
---------------------------------------------
-------------------group 1-------------------
someRandomFile.php A:\iWant\someFolder
someRandomFile.php A:\iWant\someFolder
someRandomFile.php A:\iWant\someFolder
---------------------------------------------
-------------------group 2-------------------
someRandomFile.php A:\iDontWant\someFolder
someRandomFile.php A:\iDontWant\someFolder
---------------------------------------------
-------------------group 3-------------------
someRandomFile.xml A:\iWant\someFolder
someRandomFile.xml A:\iWant\someFolder
---------------------------------------------
-------------------group 4-------------------
someRandomFile.xml A:\iDontWant\someFolder
someRandomFile.xml A:\butWathever\someFolder
---------------------------------------------
-------------------group 5-------------------
someRandomFile.xml A:\iWant\someFolder
someRandomFile.xml A:\iWant\someFolder
---------------------------------------------
---------------------------------------------
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)