using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^---+\r?\n---+[\w ]+---+(?!(?:\r?\n.*iDontWant.*$)+\r?\n---)(?:\r?\n.*$)+?(?=\r?\n---+$)";
string input = @"---------------------------------------------
-------------------group 1-------------------
someRandomFile.php A:\iWant\someFolder
someRandomFile.php A:\iWant\someFolder
someRandomFile.php A:\iWant\someFolder
---------------------------------------------
-------------------group 2-------------------
someRandomFile.php A:\iDontWant\someFolder
someRandomFile.php A:\iDontWant\someFolder
---------------------------------------------
-------------------group 3-------------------
someRandomFile.xml A:\iWant\someFolder
someRandomFile.xml A:\iWant\someFolder
---------------------------------------------
-------------------group 4-------------------
someRandomFile.xml A:\iDontWant\someFolder
someRandomFile.xml A:\butWathever\someFolder
---------------------------------------------
-------------------group 5-------------------
someRandomFile.xml A:\iWant\someFolder
someRandomFile.xml A:\iWant\someFolder
---------------------------------------------
---------------------------------------------
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}