re = /^---+\r?\n---+[\w ]+---+(?!(?:\r?\n.*iDontWant.*$)+\r?\n---)(?:\r?\n.*$)+?(?=\r?\n---+$)/m
str = '---------------------------------------------
-------------------group 1-------------------
someRandomFile.php A:\\iWant\\someFolder
someRandomFile.php A:\\iWant\\someFolder
someRandomFile.php A:\\iWant\\someFolder
---------------------------------------------
-------------------group 2-------------------
someRandomFile.php A:\\iDontWant\\someFolder
someRandomFile.php A:\\iDontWant\\someFolder
---------------------------------------------
-------------------group 3-------------------
someRandomFile.xml A:\\iWant\\someFolder
someRandomFile.xml A:\\iWant\\someFolder
---------------------------------------------
-------------------group 4-------------------
someRandomFile.xml A:\\iDontWant\\someFolder
someRandomFile.xml A:\\butWathever\\someFolder
---------------------------------------------
-------------------group 5-------------------
someRandomFile.xml A:\\iWant\\someFolder
someRandomFile.xml A:\\iWant\\someFolder
---------------------------------------------
---------------------------------------------
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end