# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.(?:js|css)\K\?v=\d+//gm;t' <<< "script.js?v=123
CSS.css?v=3456"