$re = '/\.(?:js|css)\K\?v=\d+/m';
$str = 'script.js?v=123
CSS.css?v=3456';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;