use strict;
my $str = 'script.js?v=123
CSS.css?v=3456';
my $regex = qr/\.(?:js|css)\K\?v=\d+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";