using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(?:js|css)\K\?v=\d+";
string substitution = @"";
string input = @"script.js?v=123
CSS.css?v=3456";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}