const regex = /\.(?:js|css)\K\?v=\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(?:js|css)\\K\\?v=\\d+', 'gm')
const str = `script.js?v=123
CSS.css?v=3456`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);