re = /\.(?:js|css)\K\?v=\d+/m
str = 'script.js?v=123
CSS.css?v=3456'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result