using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[$]([{])?([0-9]+)?(?(2)|(?:TM_FILENAME))(?(1)(?(2)[:].+|[\/].+[\/].*[\/])})";
string input = @"If-Then-Else Conditionals in Regular Expressions
http://www.regular-expressions.info/conditional.html
$TM_FILENAME //GOOD
$1 //GOOD
${1:} //BAD: empty default value
${1:a} //GOOD
${TM_FILENAME/[\.]/_/} //GOOD
${TM_FILENAME:a|b} //BAD: cannot set default value to static var
${TM_FILENAME/} //BAD: illegal: only one `/` (need3)
${TM_FILENAME/a/} //BAD: illegal: only two `/` (need3)
${TM_FILENAME/a//} //GOOD: not empty between first two `/`
${TM_FILENAME//abc/} //BAD: this should not match: empty between first two `/`
${TM_FILENAME/a//a} //BAD: not `}` after last `/`
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}