import Foundation
let pattern = #"[$]([{])?([0-9]+)?(?(2)|(?:TM_FILENAME))(?(1)(?(2)[:].+|[\/].+[\/].*[\/])})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
If-Then-Else Conditionals in Regular Expressions
http://www.regular-expressions.info/conditional.html
$TM_FILENAME //GOOD
$1 //GOOD
${1:} //BAD: empty default value
${1:a} //GOOD
${TM_FILENAME/[\.]/_/} //GOOD
${TM_FILENAME:a|b} //BAD: cannot set default value to static var
${TM_FILENAME/} //BAD: illegal: only one `/` (need3)
${TM_FILENAME/a/} //BAD: illegal: only two `/` (need3)
${TM_FILENAME/a//} //GOOD: not empty between first two `/`
${TM_FILENAME//abc/} //BAD: this should not match: empty between first two `/`
${TM_FILENAME/a//a} //BAD: not `}` after last `/`
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)